nds
r4 cards, r4 ds
ENGLISH   CHINESE
2017 R4ISDHC DUAL-CORE for 3DS/ NDSLL/NDSI/NDSL/NDS  

Not need 3DS V11.4.0-37 and DSI V1.45Upgrade Firmware

Updated Date:[2016/12/13]

Please choose the language version of the kernel for your card.